Once You Know, You Newegg
Results 1 to 5 of 5

Thread: VM Hypervisor failed to enter an online state in a timely fashion

  1. #1
    Join Date
    Sep 2010
    Location
    Leiden, the Netherlands
    Posts
    3,029

    VM Hypervisor failed to enter an online state in a timely fashion

    I have a box with about 30 Cosmology@Home VM's waiting to get finished.
    They're all supposed to be 25 minute jobs, but each has run for 10 minutes -several times- before stopping, each time at about 33%, with this infuriating message.
    Each VM gets created with too little video RAM (a mere 2MB), too...

    A solution anyone?
    Last edited by Dirk Broer; 09-01-2017 at 11:00 PM.

  2. #2
    Join Date
    Jul 2003
    Location
    Sydney, Australia
    Posts
    5,184
    Its the most annoying message isn't it?

    I tried updating Virtual Box to the latest version by manually downloading from the site - of course you must close BOINC when you do this. Then reboot and try. Watch it to see if the tasks get beyond the critical 10 minute mark.

    This stupid message is why I prefer to avoid any virtual box projects.

  3. #3
    Join Date
    Sep 2010
    Location
    Leiden, the Netherlands
    Posts
    3,029
    Updated to 5.1.26, but to no avail.
    Even more annoying was that upon reboot all my SRBase-long WUs suddenly started anew -and they were already over the deadline.

    The whole issue is about (lack of) connectivity. Default the VMs just get a NAT nic, but that's not enough.
    I had already added the 'virtual box host-only adapter' NIC to all VMs, and I now also added the 'Bridged adapter' with option 'Microsoft Hyper-V network adapter'.
    We'll see...
    Last edited by Dirk Broer; 09-02-2017 at 10:34 AM.

  4. #4
    Join Date
    Sep 2010
    Location
    Leiden, the Netherlands
    Posts
    3,029
    Quote Originally Posted by Dirk Broer View Post
    I had already added the 'virtual box host-only adapter' NIC to all VMs, and I now also added the 'Bridged adapter' with option 'Microsoft Hyper-V network adapter'.We'll see...
    The first step was good, the latter wasn't good at all. When I disabled the 'Bridged adapter' I was able to start a VM from the VM-console. Unfortunately not a single Cosmology WU reacted to that, so I stopped the BOINC-client and restarted it. Now a Cosmology WU is running.....and it is past the 10 min. runtime too....bingo! It took 33 minutes, and it arrived on the Cosmology server.
    Now the other 28...

    Did I already mention that this was seemingly a Windows-only problem? My Linux boxen have had no problems with the Cosmology VMs.
    You need to check the Firewall you're using under Windows to let vbox run well too, btw.
    Last edited by Dirk Broer; 09-03-2017 at 02:29 AM.

  5. #5
    Join Date
    Sep 2010
    Location
    Leiden, the Netherlands
    Posts
    3,029
    Cosmology is running fine now, without need to interfere in the VMs manually -either in Windows or with Linux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •